Rubygems not updating

I cleaned up the previous versions by issuing the “gem cleanup” command which did remove the previous versions of the rubygems-update gem however the gem command still output version 1.1.1.I tried all sorts of other methods such as updating rubygems-update to version 1.2.0, verifying the permissions of the gem application file, and a bunch of other stuff but none of it worked.The interface for Ruby Gems is a command-line tool called gem which can install libraries and manage Ruby Gems.

The public repository helps users find gems, resolve dependencies and install them.

The server that would not install the request-log-analyzer gem showed version 1.1.1 for the gem command as shown below.

Gem Command Version Output: So I figured that maybe if I cleaned up the previous installs of rubygems-update that it would resolve the issue.

(see [1] below for a larger discussion) In order to avoid this problem, when you update a gem, bundler will not update a dependency of that gem if another gem still depends on it. If bundler needs to update a gem that another gem depends on, it will let you know after the update has completed.

If you want to update every gem in the Gemfile to the latest possible versions, run: and your test suite in your back pocket.